Welcome To The War & Tactics Forum => WaT Tech Stuff: Forum Features, How-to´s, Q&A => Topic started by: Heinrich505 on 11 October 2009, 21:12:20



Title: Problem with Comment Section not Scrolling with Text
Post by: Heinrich505 on 11 October 2009, 21:12:20
TechAdmin,
  Recently I noticed that if I type a lot of text in this very box, suddenly I cannot see the line I am typing on, except for the moment that I hit the key, because the line then bounces up from the line being typed.  For short messages this is no problem, but at times I get verbose, typing a lot of text, and cannot really see what I am typing.  I hadn't seen this problem for quite a while, and only recently, perhaps in the past few months, has this started to occur.  It is not insurmountable, and I can always type in Word and then cut and paste, but I don't know why this would be suddenly happening.  I have to use the side bar arrow or the mouse wheel to move the text down to the bottom and correct what I wrote.  It is almost as if I've reached some sort of limit to the text that can be typed, and once the bar on the side of the box is activated, then I have the problem.  I am not sure how many lines it takes before I end up defaulting into this situation.  In this case I've typed 14 or so lines and the problem did not happen here.  However, the problem happened in my post about a book I was recommending, Bloody Streets.  I didn't count the lines there, but that just occurred today, with the problem I mention.  However, it doesn't seem to be happening here.  Curious.

  I am using a Dell XPS, with Windows XP, and Internet Explorer.  I thought I would toss that out to see what you thought. 

                                                      Heinrich505


Title: Re: Problem with Comment Section not Scrolling with Text
Post by: TechAdmin on 11 October 2009, 22:32:20
Thanks for advising, I have noted it on my (MacMini) machine, too.

What is your connection rate and your RAM?

I think, your analysis is right, we have reached some limits of current internet technology for medium equipped rigs. As far as I could investigate, it simply is a block from your browser when trying to parse all the moving smileys and rotating banners, too much input for your browser to parse if the browser cache is below 1 GB, this setting not only depending on RAM but also on bandwith in combination (the high-end rig users won´t see this prob, enough RAM and cache and it doesn´t appear...).

SOLUTIONS:

From user side:


- Use the scroll wheel a bit, it should refresh the page and you see again where you are (that is what I do, as I run a meager Mac Mini, if I move the text box to not display smileys I am usually fine).

- in your browser preferences, set your cache memory to the max you can afford (cache memory describes the space your browser will reserve in RAM/disc to store data like image, repretive stuff, etc.)

From forum/tech side:

- Replace animated .gifs with static ones in the text posting box, and also transfer the animated gifs to the "more" section of smileys.

I am (yet) reluctant to do the latter at the moment, as with the before mentioned solutions the problem can be covered and I am assuming that only we half stone age equipped guys will see it (as TechAdmin: Never run a high-end rig! YOu won´t understand what your low end users see!).

Still, as the idea is to serve our members, if this should become anything close to a show stopper for more than a few, this is what I am going to do (change to static smileys). I have no clue yet whether this affects the majority or just a few of our members, I shall set up a poll to get some feedback.

Contact me on PM for further discussion if this anwer does not solve your problem or for other reasons results not satisfactory.

TA

TechAdmin,
  Recently I noticed that if I type a lot of text in this very box, suddenly I cannot see the line I am typing on, except for the moment that I hit the key, because the line then bounces up from the line being typed.  For short messages this is no problem, but at times I get verbose, typing a lot of text, and cannot really see what I am typing.  I hadn't seen this problem for quite a while, and only recently, perhaps in the past few months, has this started to occur.  It is not insurmountable, and I can always type in Word and then cut and paste, but I don't know why this would be suddenly happening.  I have to use the side bar arrow or the mouse wheel to move the text down to the bottom and correct what I wrote.  It is almost as if I've reached some sort of limit to the text that can be typed, and once the bar on the side of the box is activated, then I have the problem.  I am not sure how many lines it takes before I end up defaulting into this situation.  In this case I've typed 14 or so lines and the problem did not happen here.  However, the problem happened in my post about a book I was recommending, Bloody Streets.  I didn't count the lines there, but that just occurred today, with the problem I mention.  However, it doesn't seem to be happening here.  Curious.

  I am using a Dell XPS, with Windows XP, and Internet Explorer.  I thought I would toss that out to see what you thought.  

                                                      Heinrich505